Wrong send date

Skip Navigation LinksHome  /  Support  /  Forums  /  FireMail for .NET (v1.x)  /  Display Thread

FireMail for .NET (v1.x) Forum

 May 18 2011 8:38 AM
Hello,

We have some problems with our email reception because the reception date is wrong. Our OS is in french (canada) and the date is 3 months in the past. If we change the reginal settings to english (us) we don't have the problem anymore.

Can you help me plz ?
 May 18 2011 10:12 AM
Posted by a ceTe Software moderator
Hello,

There is nothing in our DynamicPDF FireMail for .NET API which is causing this behavior. The product API is indenednt of the language which you are using in your system. Please make sure that you are setting correct network time and this should work for you.

Thanks,
ceTe Software Support Team.
 May 18 2011 10:37 AM
The date and hour on our server is correct.
The only difference is the regional setting.
I tried the firemail on the same server with the regional setting set to French (canada). The problem was here. And after I change the regional setting to English (United state) and no problem. So I think it's not a problem with our server... Can you try the same test ?
 May 18 2011 1:57 PM
Posted by a ceTe Software moderator
Hello,

Please run the below code that uses just the .NET API to send the test email from your server with both regional settings and see if this causes the send date to be incorrect.

            MailMessage mail = new MailMessage();          
            mail.From = new MailAddress("from");
            mail.To.Add("to");          
            mail.Subject = "Test Email";
            mail.Body = "Test Email Body";          
            SmtpClient smtp = new SmtpClient("mail server");
            smtp.Send(mail);

Let us know the outcome of this test so we can advise you accordingly.

Thanks,
ceTe Software Support Team. 
 May 18 2011 3:31 PM
Hello,

I tried the code in both regional settings and it work correctly with no date error.
 May 18 2011 5:04 PM
Posted by a ceTe Software moderator
Hello,

Please send the below information to support@cete.com so we can look into this issue further.

1.Name and Version of the OS of the server where you are running the FireMail code.
2.Version of FireMail dll being used.
3.Screenshots on how the regional settings are changed.
4.Code you are using to send the email.

Thanks,
ceTe Software Support Team.
 Sep 21 2011 5:01 PM
Posted by a ceTe Software moderator
Hello,
 
A bug fix has been released that fixes the wrong send date issue described above, if anyone needs a new build please send an email to support@cete.com referring to the URL of this forum post requesting the new build.

Thanks,
ceTe Software Support Team.

All times are US Eastern Standard time. The time now is 2:30 PM.