Simple Report Example

Laying out a report in DynamicPDF Designer is very simple. In this example we will walk step by step in setting up a simple report using DynamicPDF Designer. The report layout will be saved as a DLEX file which can then be referenced from within DynamicPDF ReportWriter code.

1. Open the DynamicPDF Designer

Open the Designer from the Start menu (Start -> All Programs -> DynamicPDF [version] for [platform] -> DynamicPDF Designer) or double click on the DynamicPDF Designer shortcut installed on the desktop.

2. Open and Save a New ReportFile

          On the File menu select "New"

                OR

          Click on the new file icon

                OR

          Press Ctrl+N.

          Any new report first specify a save location and name before working on the file. Report Files will always be given a DLEX extension.

Note: Ensure that the DLEX file is saved in a location accessible by the DynamicPDF ReportWriter application.

Figure 1 - A new blank report in DynamicPDF Designer

3. Layout Report

Report elements can now be placed on the blank report in a drag and drop fashion (see the "Elements of a Report" topic for more details on  each  element). All sizes below are listed in points. To change the units for Designer click on the "Layout" menu, select  "Units" and click "Points" (for conversions there are  72 points   per inch) or "Inches" or "Centimeters".

       Drag and drop the following elements:

       1. "Record Box" into the "Detail" section of the report. Change the Record Box’s properties in the "Properties" window: DataName = CompanyName, Width = 512, X = 0 and Y = 0.

       2. "Label" into the "Header" section of the report. Change the Label’s properties in the "Properties" window: FontSize = 18, Text = CustomerList, Height = 20, X = 206 and Y = 0.

       In the properties window, from the drop down list select the Report. Resize the Report’s Appearance Properties in the "Properties" window as follows: DetailHeight = 14, FooterHeight = 0 and HeaderHeight = 22.

4. Save and Close the DLEX file

         On the File menu,  click "Save"

    OR

		Click the save icon

    OR

		Press Ctrl+S.

		To close the Designer,

		On the File menu,  click "Close"

     OR

		Click the "X" in the upper right corner.

5. Referencing the DLEX file from Code

To create the final PDF report, the saved DLEX file can now be used in ReportWriter DocumentLayout class in your code.

Please refer to the DynamicPDF DLEX section of the Help Library for more information on using DLEX files from within DLEX.

In this topic