Cannot load TypeLib

Skip Navigation LinksHome  /  Support  /  Forums  /  DynamicPDF CoreSuite for COM/ActiveX (v6)  /  Cannot load TypeLib

DynamicPDF CoreSuite for COM/ActiveX (v6) Forum

 Mar 14 2019 3:13 PM
I'm migrating an application to a new server and am having trouble getting v6 of Generator For COM running. In my VBScript I have
<!-- METADATA TYPE="typelib" UUID="{DF9225FE-94A4-490D-8CAD-E8366CE621D3}"-->
which is erroring as follows:

Active Server Pages error 'ASP 0224'
Cannot load TypeLib
/global/includes/dynamic_pdf/typelib.asp, line 1
Cannot load Type Library specified in the METADATA tag.

I've found these threads, but they don't seem to help me:

I've given "everyone" full access to the bin folder as a test and it still doesn't work

I tried installing v8 and it works fine except my license is for v6.

Any thoughts?
 Mar 19 2019 4:06 AM
Posted by a ceTe Software moderator

You are getting error most likely because the version 6 DynamicPDF for COM/ActiveX product is not correctly installed on the machine.

It is suggested to download the latest v6 DynamicPDF for COM/ActiveX product by logging into our : CustomerArea  using your version 6 DynamicPDF for COM/ActiveX product serial number. Uninstall the currently installed product. Restart the system. Install the v6 product using latest downloaded product installer file. The run the VBScript code sample included with the product download. Once you successfully run the VBScript code sample then try running your application.

If you continue getting any issues then please send over the following information to so we can look into it further.

1.        Are you able to run the VBScript code sample included with the product download?
2.        If you are getting error then please send over the screenshot showing all details.
3.        Operating system details where in you are getting error: Name, x86 or x64.
4.        If VBScript code sample works fine and you get error on running your application then send over full error message.
5.        Exact version and build number of the DynamicPDF for COM/ActiveX product installed on your system.

ceTe Software Support Team.
 Apr 16 2019 10:19 AM
I think the main issue I was having was that I had .Net 4.x installed, but not 2.0 or 3.5 which is required by the tool. Once I installed 3.5 it all started working for me.

All times are US Eastern Standard time. The time now is 3:29 PM.