error with typelib

Skip Navigation LinksHome  /  Support  /  Forums  /  DynamicPDF CoreSuite for COM/ActiveX (v8)  /  error with typelib

DynamicPDF CoreSuite for COM/ActiveX (v8) Forum

 Feb 25 2017 1:57 PM
We have recently moved to a new server. I ran the installation on the new server and installed a development license key while we are in testing.  My host tells me the new server is a plesk server...means nothing to me.  I think it is UNIX server running virtual windows.  Anyway, I keep getting this error:
Cannot load TypeLib

/GP_Report.asp, line 2

Cannot load Type Library specified in the METADATA tag.

Searching the web, I see similar problems where the answer was to put 'read' permissions on the install folder.  My server host says they did that, to no avail. Here is the typelib line:
<!-- METADATA TYPE="typelib" UUID="{DF9225FE-94A4-490D-8CAD-E8366CE621D3}"-->

So, are there any other suggestions?  Can anyone explain why this would happen if, indeed, read permissions were set properly?  For example, if the install failed, would that cause the error?  At this point, I can't even tell if the installation was successful or not.
 Feb 26 2017 11:30 AM
Follow up...this comes from my server host:

"...However, when we tried to install DynamicPDF in plesk2 server, the DynamicPDF is still not working properly.  It seems, Plesk system has it own security that blocks access to DynamicPDF directory even when the directory read permission has been added."

Any suggestions from anybody?  Anybody have this running in a plesk system?


 Feb 27 2017 10:28 AM
Posted by a ceTe Software moderator
Hello Jim,

When you install the product on a server, the installer places all the product files (dll, tlb etc) in the program files folder and registers the dll and tlb files. Please take a look at the following link for more information on where the product files are located on the server.

When the product methods are called from your asp web application to generate the PDF, the above mentioned product files will be loaded in memory by IIS and those files should have read permissions, otherwise you may get the type library error. On a normal server, the read permissions are typically granted by the server at the time of installation. We are not familiar with plesk system and we are not sure why it restricts permissions to the default product installation folder.

You can try and install the product at a different location on the server, but your server host provider has to make sure that this new location has permissions and that plesk system is not blocking access to the product files at the new location. If this is possible then uninstall the product from Add Remove Programs, run the installer again and change the destination folder to a different location and complete the installation.

ceTe Software Support Team.

All times are US Eastern Standard time. The time now is 6:54 AM.